Please Note: We are no longer using forums to facilitate standard support. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

1.5.2 Upgrade Failed

  1. I tried to upgrade to 1.5.2 using first the WordPress automatic plugin update procedure and after it erased the previous version, it failed to install the new version. Everything disappeared now!!!

    Then I tried to upgrade by downloading the zip and uploading it to the server and it gets hung up while "unpacking the package" and gives me this error message: Could not create directory. /var

    The worst part is that I mistakenly did this in my production server thinking that I was doing it in the test server, and now everything (forms and entries) has disappeared!!!!

    Please help!!!


    Posted 4 years ago on Monday May 9, 2011 | Permalink
  2. Sounds like your WordPress site didn't handle the automatic update correctly. It deleted the old version and then didn't install the new version.

    Go to the Plugin Downloads page, download the Gravity Forms v1.5.2 zip file and install it manually via FTP.

    You may need to FTP into your site and if there is a wp-content/plugins/gravityforms folder you will need to delete it. That is why you can't upload the zip file manually because the folder already exists. So delete it via FTP, and then re-install v1.5.2 manually.

    Posted 4 years ago on Monday May 9, 2011 | Permalink
  3. Carl, thanks for your prompt response but before I follow your instructions I wonder if indeed the forms I had and all the entries accumulated have disappeared permanently.

    BTW, I had done a site backup using the wp-db backup plugin before trying to upgrade, but I don't know if that backup contains the forms and entries that existed before.

    I just want to make sure that I can somehow salvage the forms and entries.

    Posted 4 years ago on Monday May 9, 2011 | Permalink
  4. Your forms and entries are stored in your WordPress database, so they aren't impacted by your plugin files being deleted. Re-install the plugin files properly and the forms and entries will still be there when you activate the plugin.

    Posted 4 years ago on Monday May 9, 2011 | Permalink
  5. Carl, sorry to bother again, but it didn't work.

    I followed your instructions: (1) FTP into my site, and deleted the wp-content\plugins\gravityforms folder; (2) went back to the WordPress dashboard and did a manual upload of the zip file I downloaded from your site.

    However, it got hung up again while trying to install it. I got the following message =>> Could not copy file. /var/[**i excluded server & folder info for security reasons**]/wp-content/plugins/gravityforms/images/percentbar_bg.png

    Is this a problem that could be resolved by doing a "more manual" installation using FTP? I use FileZilla but would need instructions for how to do it since I have always relied on the WordPress dashboard.


    Posted 4 years ago on Monday May 9, 2011 | Permalink
  6. It sounds like you have server file permission issues which is why the automatic update and the subsequent manual upload did not work. The could not copy file is a server sercurity issue related to file permissions.

    You are going to have to install via FTP.

    Unzip the Gravity Forms zip file on your local machine. It should create a folder called gravityforms with the plugin files within it.

    FTP into your site and browse to wp-content/plugins. Delete any existing gravityforms folder if one exists. Upload the gravityforms folder from your local machine to the wp-content/plugins folder.

    It should create a folder called gravityforms with all the plugin files in it.

    Then browse to your Plugins page and activate Gravity Forms.

    Installing plugins via FTP is a much more reliable way to install plugins. The WordPress uploader isn't always perfect and depending on file permissions and server issues it can fail.

    Posted 4 years ago on Monday May 9, 2011 | Permalink
  7. Carl,
    Same happened to me but your solution worked a treat!

    Thanks for the detailed instructions!

    Posted 4 years ago on Thursday June 23, 2011 | Permalink

This topic has been resolved and has been closed to new replies.

Support Tickets

Open A New Support Ticket
 Open A New Priority Support Ticket *

* Developer license holders only