Please Note: We are no longer using forums to facilitate standard support. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Conflict between Gravity Forms 1.5.2.8 and AdRotate 3.6.3

  1. Gustave
    Member

    Hi,

    I'm using Wordpress 3.2.1 and both plugins Gravity Forms 1.5.2.8 and AdRotate 3.6.3
    But when I activate the AdRotate plugin the textareas in my contact form is limited to about 200 characters in the entries in admin panel.
    I checked my database and I have the full messages in the wp_rg_lead_detail_long table. But I can't see it neither on the admin notification email nor on the entries.
    How can I fix this ? Is the problem on AdRotate or Gravity Forms ?

    Thanks

    Posted 3 years ago on Tuesday July 19, 2011 | Permalink
  2. This is a problem with AdRotate. It's interfering with Gravity Forms code. We have a copy of AdRotate that we are going to test with and see if we can determine what it's doing wrong, but ultimately it's going to be an issue that requires a change in AdRotate to resolve.

    Posted 3 years ago on Tuesday July 19, 2011 | Permalink
  3. Gustave
    Member

    Thanks Carl !
    I also posted the same content to the AdRotate forum ;) I'm waiting for their answer. But if you can take a quick look and tell me what can be the issue and how to fix it would be really great !

    Posted 3 years ago on Tuesday July 19, 2011 | Permalink
  4. Gustave
    Member

    Am I the only one with this issue ? Please help ! Thanks ;)

    Posted 3 years ago on Wednesday July 20, 2011 | Permalink
  5. Gustave
    Member

    Hi ! I just got an answer from the developer of AdRotate.
    Of course, for him the issue comes from Gravity Forms. Here's his answer :

    AdRotate does not impose limitations on ANY textfields, not it's own and certainly not fields outside AdRotate.

    Similar issues have been reported. I cannot test them since Gravity forms is not free or requires some sort of license.

    However, simple logic tells me that AdRotate can not cause this. Reason: Any and all values passed on via forms or variables are prefixed with "adrotate_" thus. If there is a conflict Gravity forms logically does not prefix stuff and assumes globals of sorts which are the same as AdRotates.

    This is not an issue i should be fixing.

    Carl, since I paid for your plugin (actually I use it with all my clients, I have purchased many licences for them), I would be glad if you could take a look at this please. Even if you find out that the issue comes from AdRotate maybe you can come with a fix and I'll communicate it to the AdRotate's developper.

    AdRotate is a great plugin for banner rotation management and Gravity Forms is simply perfect ! It would be a shame to have to choose between one of them ;)

    Thanks !

    Posted 3 years ago on Wednesday July 20, 2011 | Permalink
  6. We are unable to replicate this issue locally using the AdRotate plugin. It works fine for us with Gravity Forms which means it's an issue specific to your site setup. This could be a specific AdRotate settings setup, or it could be related to a theme or another plugin you are using that introduces this issue.

    In order to look into it we'd have to debug this issue on your site. If you send us a WordPress admin login AND an FTP login for your site via our Contact Us form and reference this forum post we'd be glad to take a look and see what is going on.

    Posted 3 years ago on Wednesday July 20, 2011 | Permalink
  7. There was a previous discussion of the 200 character limit in textarea fields:
    http://www.gravityhelp.com/forums/topic/textarea-limited-to-200-characters

    Posted 3 years ago on Thursday July 21, 2011 | Permalink
  8. Gustave
    Member

    I saw that thread but there's no answer on how to solve it. I'm sending the info you requested Carl. Thanks !

    Posted 3 years ago on Thursday July 21, 2011 | Permalink
  9. We received the information and our lead developer will be taking a look to see what is going on.

    Posted 3 years ago on Thursday July 21, 2011 | Permalink
  10. The AdRotate plugin is setting the locale of your site to your configured value. There is nothing wrong with that, but it does affect one of the queries in Gravity Forms preventing the full content of fields from being displayed (when over 200 chars).
    I have made a change to your Gravity Forms install to overcome this problem, so you should be good to go. We will add the fix to the 1.6 release, so you will be OK when upgrading to that version.

    Posted 3 years ago on Thursday July 21, 2011 | Permalink
  11. Hi, since we are experiencing the same problem, is it possible to see the solution? Could you paste code modifications needed?

    Thanks

    Posted 3 years ago on Tuesday October 4, 2011 | Permalink
  12. @lorenzo What version of Gravity Forms do you have installed and are you using AdRotate?

    Posted 3 years ago on Tuesday October 4, 2011 | Permalink
  13. Hi Gravityguys :-), I have same problem with adrotate.
    I use 1.5.3 version and 3.6.6 (last) of ADrotate. Please post here the solution or send me PM.

    Posted 3 years ago on Saturday October 22, 2011 | Permalink
  14. Luigi
    Member

    Hi,
    I have the same problem ! [ http://consulenza.avvocato.it/consulenza-legale-on-line/ ]
    WP 3.0.4
    AdRotate 3.6.3
    Gravity Forms 1.5.3
    Can you help me ?
    Thanks.

    Posted 3 years ago on Sunday October 23, 2011 | Permalink
  15. Have you (Luigi or Stefan) tried the 1.6 release candidate on a test site, to see if the change we made helps your situation? 1.6 is not at the final release yet, but the release candidate is very stable.

    Posted 3 years ago on Monday October 24, 2011 | Permalink
  16. Hi Chris,
    yes I tried Gravity Forms v1.6 Release Candidate 5. And the problem remains, unfortunately, does not change anything.

    Posted 3 years ago on Thursday October 27, 2011 | Permalink
  17. I will have Alex take a look at this. Thank you for your patience.

    Posted 3 years ago on Friday October 28, 2011 | Permalink
  18. After a little more research, it looks like setting the locale the way the Adrotate does, is a problem. It is changing the locale for all categories (LC_ALL), which changes the way numbers are handled (more specifically, it changes the thousand and decimal separators). I have tried changing things on the Gravity Forms end to prevent the problem, but I haven't been able to get around it.
    The only solution I can come up with is a minor change to the Adrotate plugin.

    Replace the following line of code in the adrotate.php file, around line 19.

    setlocale(LC_ALL, get_locale().'.'.DB_CHARSET);

    with the following two lines:

    setlocale(LC_ALL, get_locale().'.'.DB_CHARSET);
    setlocale(LC_NUMERIC, 'C');
    Posted 3 years ago on Friday October 28, 2011 | Permalink
  19. Hi Alex,
    I adopted your change right now and it seems that everything goes well, the messages are not truncated.

    Now I will monitor all if I meet other problems,I will post here.

    A big thank you, I owe you a beer!

    Posted 3 years ago on Thursday November 3, 2011 | Permalink
  20. Luigi
    Member

    Very good !

    Posted 3 years ago on Friday December 2, 2011 | Permalink
  21. I'm running into the same thing with another plugin that is doing setlocale globally. But in this case I actually need LC_NUMERIC to be in my locale. I cannot change it to C. What exactly are my options here? Where is setlocale safe to use in another plugin so it doesn't break GF?

    Posted 3 years ago on Wednesday May 9, 2012 | Permalink
  22. After discovering mostly undocumented Wordpress function number_format_i18n, I have dropped my global setlocale. Gravity Address field validation process now works without problems.

    Posted 3 years ago on Wednesday May 9, 2012 | Permalink

This topic has been resolved and has been closed to new replies.

Support Tickets

Open A New Support Ticket
 Open A New Priority Support Ticket *

* Developer license holders only