Please Note: We are no longer using forums to facilitate standard support. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Date format changes when saved to custom field

  1. Hi,

    I'm having issues with date formats/custom fields and having searched for hours, I can't work out what the problem is...

    I've got a custom post type 'Course', with custom fields for start and end dates (setup via Custom Field Template plugin).

    In my Gravity Form, I have a Custom Field with field type set to Date. I've set date format to be dd/mm/yyyy.

    When submitted, this appears fine in the form entry, but when in the custom field (in the 'course' post), it changes format to yyyy-mm-dd. This happens even if the corresponding custom field is just a plain text box.

    Any clues as to what's happening here would be greatly appreciated!

    Thanks,
    Sarah

    Posted 3 years ago on Monday September 19, 2011 | Permalink
  2. The date format options have changed in the latest version. Which version are you using currently? It will help us resolve the issue. Thanks.

    Posted 3 years ago on Monday September 19, 2011 | Permalink
  3. I'm using version 1.5.2.8

    Thanks!

    Posted 3 years ago on Monday September 19, 2011 | Permalink
  4. What plugin are you using for the custom fields, and can you post a link to your site?

    It sounds like the custom fields plugin, or your template (wherever you are using the date value) is translating the date between different formats. If the date is stored correctly in the entry, it's being translated somewhere along the way.

    Posted 3 years ago on Tuesday September 20, 2011 | Permalink
  5. The plugin is the Custom Field Template plugin: http://wordpress.org/extend/plugins/custom-field-template/

    You can find the form on the site here: http://alpha.xssl.net/~ptcf/news/course-form/

    I'm guessing it's more likely to be the plugin rather than the template, as the value is getting changed in the admin area, not just in the front-end... Just can't work out why it's doing it though!

    Thanks

    Posted 3 years ago on Tuesday September 20, 2011 | Permalink
  6. Do you have any suggestions on this? Many thanks in advance...

    Posted 3 years ago on Thursday September 22, 2011 | Permalink
  7. Hi, can you export the form and email it to me at chris@rocketgenius.com please? It will give me something to start with.

    Thanks.

    Posted 3 years ago on Saturday September 24, 2011 | Permalink
  8. Hi Chris, I have just emailed you the form export as requested.

    Many thanks.

    Posted 3 years ago on Monday September 26, 2011 | Permalink
  9. Hi !
    I'm experiencing the same issue. In my case using 1.6.rc1 version

    Posted 3 years ago on Tuesday September 27, 2011 | Permalink
  10. I have replicated this issue locally. We will be correcting this in the next Gravity Forms v1.6 Release Candidate release later this week. We will be updating it so that the custom field value stored will honor the date format settings you configure on the field.

    Posted 3 years ago on Tuesday September 27, 2011 | Permalink

This topic has been resolved and has been closed to new replies.

Support Tickets

Open A New Support Ticket
 Open A New Priority Support Ticket *

* Developer license holders only