Please Note: We are no longer using forums to facilitate standard support. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Fatal Error with most themes and plugins

  1. agolden42

    Purchased and installed Gravity Forms yesterday and have been spending most of the time since trying to work around the constant Fatal Errors I'm getting when using different plugins and trying different themes.

    The error message is always Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 491520 bytes) in ... on line 235

    Memory size and line number are different in each case, but it's the same message. I not only deactivated but uninstalled all other plugins and themes. It works with some plugins but then if I install something new, I get the error. Or, I tried a different theme and got the error. If I delete the plugin/theme manually through FTP things go back to normal.

    I started out using the most recent stable version of Gravity Forms and had the problem, so I upgraded to the newest beta. It seems to be more compatible but still conflicts with a ton of plugins and themes.

    As soon as I deactivate Gravity Forms, everything else works fine.

    My website is, the forms are on and

    I'm also using the Gravity Forms Directory & Addons plugin, which I know is not you guys, but the error I receive from Gravity Forms persists even when I delete the Directory plugin.

    I've also tried increasing the memory in my php.ini file to 64MB and then to 128MB, and it didn't help. I'm using PHP5

    Any ideas?

    Posted 4 years ago on Sunday February 13, 2011 | Permalink
  2. It's a PHP memory issue. It's not a conflict with themes or plugins. It's purely a memory issue. Your site is running out of available PHP memory. It's not an error with the code, or a problem with Gravity Forms.

    Increasing the available memory in PHP.INI appears to have no impact on your WordPress site. This could be due to a couple reasons.

    The way your server is configured you may need to also increase the available PHP memory in your WordPress wp-config.php file. See this post:

    It could also be because your server is not using your PHP.INI file for php memory settings, it could be ignoring that setting. Different hosts handle this different ways. Some manage available PHP memory via a hosting control panel setting.

    I would suggest increasing the available memory in your wp-config.php file and your php.ini file. Increasing it to 64MB should be sufficient and 128MB should definitely be sufficient.

    However, I don't know what other plugins you are running. If you are running a lot of plugins and a large memory intensive theme, you may need to increase it even more.

    Posted 4 years ago on Monday February 14, 2011 | Permalink
  3. agolden42


    Thanks for the quick reply. The php.ini file I was editing to increase memory apparently was not the one my php files were using even though the server was set up for it. I located the correct php.ini, and changed the memory to 128. I also did it in the wp-config.php just to be sure. Everything works fine now.

    Posted 4 years ago on Tuesday February 15, 2011 | Permalink
  4. Good to hear! Locating the correct location of your memory settings can sometimes be tricky. Web hosts aren't always consistent and sometimes there are multiple PHP.INI files, etc. Glad you got it resolved.

    Posted 4 years ago on Tuesday February 15, 2011 | Permalink

This topic has been resolved and has been closed to new replies.

Support Tickets

Open A New Support Ticket
 Open A New Priority Support Ticket *

* Developer license holders only