Please Note: We are no longer using forums to facilitate standard support. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Fields not showing, even with conditional logic disabled

  1. Well, after much research, i came to this link (http://www.gravityhelp.com/question/why-is-there-a-style-attribute-of-displaynone-being-added-my-form-isnt-showing-up/), wich basically tell me that if the conditional logic is enabled and my theme doesnt have the function cal wp_footer(), the form will not show.

    Well, i can tell my theme have the wp_footer() call and when the conditional logic is enabled on some fields, the form simply doesnt show. Ive tried on every browser i know and the result is the same. Even in the pre-visualization (wich doesnt use my theme) i cant see the form.

    You can see my form here: http://www.produzindo.net/pesquisa-de-perfil-e-de-opiniao/

    As you can see, the style:none is there. What can i do?

    Posted 4 years ago on Wednesday August 31, 2011 | Permalink
  2. The issue is caused by either a plugin conflict or theme conflict.

    I am going to guess it's from the Superfish menu and the JavaScript error "$ is not a function." Fix your Superfish menu and I think you will find Gravity Forms with conditional logic will work.

    What you have now:

    <script type="text/javascript">
    $(document).ready(function() {
        $('#topnav ul').superfish({
            delay:       1000,
            animation:   {opacity:'show',height:'show'},
            speed:       'slow',
            autoArrows:  false,
            dropShadows: false
        });
    });
    </script>

    What it probably needs to be:

    <script type="text/javascript">
    jQuery(document).ready(function() {
        jQuery('#topnav ul').superfish({
            delay:       1000,
            animation:   {opacity:'show',height:'show'},
            speed:       'slow',
            autoArrows:  false,
            dropShadows: false
        });
    });
    </script>
    Change the $ to jQuery in two places. The formatting above does not make that very clear.

    Thank you for posting the URL to your site. It makes troubleshooting so much easier.

    Posted 4 years ago on Wednesday August 31, 2011 | Permalink
  3. Chris,

    I tried to change that function (it's within my theme), but i got nothing. Same problem.

    When i came down to try to turn off some plugins, i noticed that when i turn off sharebar, the form shows up. Do you know a workarround so i can use both plugins?

    Thanks.

    Posted 4 years ago on Wednesday August 31, 2011 | Permalink
  4. That was going to be my second suggestion. The sharebar plugin has a JavaScript error as well. I would contact the author of that plugin and see if they can fix the plugin or have a workaround.

    It has been reported before but no resolution.
    http://www.gravityhelp.com/forums/topic/form-not-displaying

    Posted 4 years ago on Wednesday August 31, 2011 | Permalink

 

Support Tickets

Open A New Support Ticket
 Open A New Priority Support Ticket *

* Developer license holders only