Please Note: We are no longer using forums to facilitate standard support. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Form not appearing on live website

  1. My form appears in the preview but not the live website. I tried switching to the 2010 theme and disabling all plug ins just to make sure there was no conflict but my form still does not appear.

    Any ideas?

    Posted 4 years ago on Sunday November 20, 2011 | Permalink
  2. Please post a link to your site.

    Does your form use conditional logic? If so, please try a simple form with no conditional logic and see if that appears. Forms with conditional logic will be hidden and then unhidden using JavaScript as needed. If the JavaScript does not work, you will never see the form. That is typically due to a theme or plugin conflict. That's why it works fine in preview.

    Please start with a link to your form so we can see exactly what it looks like. Thank you

    Posted 4 years ago on Sunday November 20, 2011 | Permalink
  3. Below is a link to the page where the form should be.

    I removed the conditional logic and it still does not work. As I said in my original post, before coming here I turned off all the other plug-ins and reverted to the 2010 theme which did not make a difference. Even with everything disabled, the form would still not show.

    Here is a list of the plug-ins I use but as I said before, disabling them did not fix anything.

    AddThis Social Bookmarking Widget Version 2.3.0
    All in One SEO Pack Version
    DB-Optimize Version 1.1
    Exclude Pages from Navigation Version 1.91
    Google Analytics for WordPress Version 4.2.2
    Google XML Sitemaps Version 3.2.6
    Gravity Forms Version 1.6.1
    MapPress Easy Google Maps Version 2.38
    Page Links To Version 2.5
    Robots Meta Version 3.3.1
    Scribe SEO Version 3.0.8
    SEO Friendly Images Version 2.6.2
    W3 Total Cache Version
    WPtap Mobile Detector Version 1.1

    Posted 4 years ago on Sunday November 20, 2011 | Permalink
  4. I can see the form on that page. Screenshot:

    This is with Windows 7 and Chrome 15.0.874.121 m. In what browser are you experiencing the trouble, or have you already found the reason it was not working?

    Posted 4 years ago on Sunday November 20, 2011 | Permalink
  5. Disabling the conditional rules made it show up. At least I think that is why but it doesn't help. The conditional rules are the main reason why we switched from our old contact form.

    Posted 4 years ago on Monday November 21, 2011 | Permalink
  6. @4WeHelp If the form doesn't show up with conditional logic enabled then it's most likely going to be a Javascript error on the page that is preventing the conditional logic from executing and displaying the fields that should be shown.

    When I look at your page, this is exactly the issue I see. There is a Javascript error, unrelated to Gravity Forms, on your page. See this screenshot:

    You need to correct this Javascript error. This is what is causing the problem with Gravity Forms, which tries to use Javascript to execute conditional logic and is unable to do so because when the browser encounters a javascript error it quits executing the remaining javascript on the page.

    Posted 4 years ago on Monday November 21, 2011 | Permalink
  7. Thanks for the help. I am guessing that the facebook error is from the addthis social media widget? Why wouldn't that have changed when we disabled all of the widgets?

    Posted 4 years ago on Monday November 21, 2011 | Permalink
  8. I'm not sure, not familiar with that plugin. If you disabled all of the plugins... then the functionality is coming from your theme and the error is in your theme itself. Plugins aren't widgets, so they are 2 different things. This social media widget may be built into your theme.

    Posted 4 years ago on Monday November 21, 2011 | Permalink
  9. As I stated in my original post I switched to the 2010 them as recommend when the plug ins were disabled and that did not make a difference.

    Posted 4 years ago on Thursday November 24, 2011 | Permalink
  10. The theme I am using is not "widget aware". Just to review what I originally posted and make sure we don't miss anything.

    I disabled all plug ins and reverted to the 2010 theme. This did not make a difference and your forms still did not work properly.
    I came here and posted that I had disabled all plug ins and reverted to the 2010 theme and it did not make a difference.
    You told me to do the same thing again.
    It still did not work
    You told me to remove the conditional setting, I did and the gravity form now shows but does not work.

    Posted 4 years ago on Thursday November 24, 2011 | Permalink
  11. If the form does not work in the live site, but works in preview, and has conditional logic, something is causing a JavaScript error. That error causes the Gravity Forms JavaScript to not reveal the form. It will always be hidden with the CSS display: none.

    I just visited the form and I can see it. Do you have conditional logic enabled now? It appears you do (on page two, clicking check boxes reveals more of the form.)

    This is the second time I have checked the form and found it to be showing and working. Is it possible that the cache plugin is causing you to see old information? Or your browser has cached information? It's working for me here, today Firefox 8 on Linux.

    What browser are you using currently?

    I would try a completely different browser and see if the form shows up properly. It has never failed to work for me. The issues you're describing are not normal for Gravity Forms and there is probably a simple explanation for what you're seeing.

    Posted 4 years ago on Thursday November 24, 2011 | Permalink
  12. 4WeHelp is not alone...I'm having the exact same issue. I've got multiple conditional logic rules in place and I'm seeing the CSS display: none attribute you speak of after a certain point in my form. I've disabled all plugins and tried the default theme to no avail.

    My page is: if you want to check it out.

    Posted 4 years ago on Sunday November 27, 2011 | Permalink
  13. Check jQuery is being loaded before the form, I had that problem. Will there be a way to move the forms JS to the end of the page?

    Posted 4 years ago on Monday November 28, 2011 | Permalink
  14. Quick update:

    I fixed my issue by un-checking the "required" attributes in my form fields that were set to have conditional logic applied. It wasn't the most optimal solution, but there seems to be some sort of conflict going on when you have those two variables set.

    Posted 4 years ago on Monday November 28, 2011 | Permalink
  15. Kevin.Hannula

    We are having the same problem.
    All plug-ins and themes have been removed. Here is a link to the page where the form should appear. As soon as the conditional logic is removed, the form appears. It appears to work fine in the preview mode.
    Please help

    Posted 3 years ago on Wednesday November 30, 2011 | Permalink
  16. As has been mentioned multiple times in this thread, if forms are not displaying when you use conditional logic it is going to be a javascript problem unrelated to Gravity Forms.

    It will either be A) there is a javascript error on the page or B) the necessary scripts have not been enqueued due to the theme not being setup properly or some sort of conflict.

    In order to be able to provide any guidance as to why any user is experiencing this you would have to provide us with a link to a page where this issue is happening. We'd have to see the issue happening in order to inspect the code and determine what is causing the problem.

    Disabling conditional logic isn't the solution. Fixing the cause is the solution. Something else on the site is causing the problem.

    If you can post a link to a page where this issue is actively happening, we can take a look and determine the problem.

    Posted 3 years ago on Wednesday November 30, 2011 | Permalink
  17. Kevin.Hannula

    I'm sorry, did I not pay enough to get actual support? Cutting and pasting your previous replies doesn't really count as helping.

    I believe I followed all of the directions in the thread above before I even started the post. I stripped down the site to only Theme 2010, PHP Purchase (Cart 66), and Gravity forms. I gave you a link to the page where the issue is "actually happening". The form is not visible, because it is hidden when any conditional logic is turn on.

    Please let me know what additional info you need to help me solve this issue.

    Posted 3 years ago on Thursday December 1, 2011 | Permalink
  18. kyle

    It looks like conditional_logic.js is not getting loaded for some reason.

    Does it work with Cart 66 disabled?

    Posted 3 years ago on Thursday December 1, 2011 | Permalink
  19. kyle

    Here's another thread with someone having issues with Cart 66: Need to download version 1.5...

    Posted 3 years ago on Saturday December 3, 2011 | Permalink
  20. bridalpr

    Hey Carl, I have the exact same issue and am not savvy enough without your expertise. Here is a link to the site, the form code is on the blockquote area. Would you be able to give me any pointers on fixing this? Thanks a million in advance, you guys have amazing support.

    Posted 3 years ago on Monday December 5, 2011 | Permalink
  21. @kyle You shouldn't have to use Gravity Forms v1.5 with Cart66. If that is the case then you should strongly complain to the Cart66 support because that is absurd. We have nothing to do with Cart66 integration, it's all handled on their end. If they have any questions or problems supporting Gravity Forms v1.6 they just need to reach out to us and we'd be glad to assist them.

    @bridalpr Your server is returning 500 server errors for the conditional logic javascript. This could be a file permission issue. See this screenshot:

    If I try to go right to the location of the script itself, it loads a blank page instead of the actual script. See this URL:

    I would suggest re-installing Gravity Forms. Either that file is missing, not fully uploaded or there is a file permission issue. If you don't know how to set file permissions then discuss this with your web host and they should be able to assist you.

    Posted 3 years ago on Monday December 5, 2011 | Permalink
  22. kyle

    Hey @carl, I agree - I'm not even using Cart66 - but Kevin.hannula said he had disabled everything but cart66 and was still having trouble. Thought it might be useful for him to know there here was another thread with the same issue using Cart 66.

    Posted 3 years ago on Tuesday December 6, 2011 | Permalink
  23. czydrm

    Hey Carl,
    This is one of those time where I have to respectfully say "bullshit" as I sneeze. Logic says that if ALL plugins except GF are disabled and ONLY the default theme is being used, then the fault MUST lie with GF. Also, I am not using any conditional logic, still I am getting "Oops! We could not locate your form." no matter what I try.

    Additionally, the forms work in the sidebar but NOT in the content area.
    I have reinstalled 1.6 twice, tried with 1.5, disabled everything, tried multiple browsers... nothing.

    Posted 3 years ago on Wednesday December 7, 2011 | Permalink
  24. It seems Gravity is very easily sticking the finger to someone else. There are so many GF integration issues on the web something must be wrong with gravity. I only got forms layout running by adding ALL GF css (which is hilariously large and complex) to the end of style.css. Call it what you like, but two days wasted is enough.
    No userfliendlyness at all when integrating, nowhere any clear ideas to be found what to do when forms get messed up, hundreds of users having css problems with GF. Answers being very technical or in denial.
    When GF functions they are the best, but the supportbase could use 'some' improvement.
    Now this very same no-show problem on (option now switched off, no cart66. ) So GF are you going to solve this or still not at home there?

    Posted 3 years ago on Tuesday December 20, 2011 | Permalink
  25. @czydrm - I did not see a link to the page with your form. Can you post that please? We'll be happy to take a look.

    There was a discussion of a WordPress issue causing this, just as you describe, where it works in a widget but not in the content area.

    Posted 3 years ago on Tuesday December 20, 2011 | Permalink
  26. @czydrm Actually logic does not dicate that it's a Gravity Forms problem. There are other non-Gravity Forms related situations that can cause this to happen.

    One of them is a server setting related to REGEX settings that impact how your site parses shortcodes. If shortcodes aren't parsed properly, the parameters in the shortcode won't be used and the form will not be found because the ID of the form is passed via a parameter.

    That actually sounds like the case in your situation because the Widget doesn't use the shortcode and it sounds like only the shortcode is what isn't working for you.

    I can assure you, the issue is going to be related to your web server configuration or other code on your site. If it was an inherent issue with Gravity Forms then everyone would be experiencing it and we have over 270,000 sites using Gravity Forms and we aren't getting reports of it.

    So before you start yelling, screaming, cussing and laying blame... rather than posting your own support request and allowing us to assist you with the issue... if you contact me directly at and supply me a WordPress admin login for your site I would be glad to take a look and see what is going on.

    @huisstijldokter We can't control plugin and theme conflicts. It's 100% out of our control. It's the nature of how WordPress plugins and themes work. There is simply nothing we can do to prevent themes or plugins from interfering with Gravity Forms code or form layouts due to the way WordPress is architected and the way CSS inheritance works.

    So before you go laying blame and pointing the finger, why don't you try simply asking for assistance because we'd be glad to help you resolve your issues.

    Let us know exactly what the problem is and we'll be glad to take a look and help you get it resolved. If the Gravity Forms related CSS isn't automatically being enqueued on the page, then there are a variety of reasons why this could be the case.

    One common issue is the theme lacking the necessary wp_head() function calls in the header.php and wp_footer() function call in the footer.php which are used to enqueue scripts and CSS into the head and foot of your site. That is the first thing you should check.

    Another common issue is how you are trying to embed the form. Gravity Forms can only automatically enqueue the necessary scripts and CSS when you are using the shortcode in a standard WordPress content loop. This isn't a Gravity Forms flaw or problem, it's simply how WordPress enqueue works.

    If you are trying to embed a form via the function call or in a theme that displays content a non-standard way, then the scripts and CSS won't be enqueued automatically and you'll need to use the enqueue function to tell it to do so.

    If you simply ask for help and provide details on the issue we'd be glad to help.

    Yelling, screaming, cussing and pointing fingers isn't going to get the issue resolved. What you should have done and what I suggest you do is posted your own support request on the support forum.

    Posting a reply to a month old post where multiple users experiencing completely different issues (although some may sound the same) is not the best way for you to have your issue reliably handled. If you want support, post your own support request or use Priority Support if you have a Developer License and our support team will work with you to resolve the issue.

    I'm closing this post. The original poster's issue was resolved. It wasn't a Gravity Forms problem, it was a Javascript error caused by something else on his site.

    If you need support, post your own support request and our support team will help you.

    Posted 3 years ago on Tuesday December 20, 2011 | Permalink

This topic has been resolved and has been closed to new replies.

Support Tickets

Open A New Support Ticket
 Open A New Priority Support Ticket *

* Developer license holders only