Please Note: We are no longer using forums to facilitate standard support. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Form not submitting

  1. Hello! I just purchased GravityForms this morning and I am so happy with the functionality BUT... and it's a big BUT... my form is not submitting when I click Send.

    When I preview the form in my WP admin and submit it there, I have no problems receiving the entry... though I am not getting an email confirmation. BUT when I go to my live site and try and submit a form, nothing happens. The entry isn't saved, I get no confirmation email and the submitter is not redirected.

    http://www.elasticmind.ca/contact-me/

    Any ideas what could be going on?

    My settings are:

    PHP Version 5.2.8
    MySQL Version 5.1.35
    WordPress Version 2.8.4
    Gravity Forms Version 1.3.4

    Posted 5 years ago on Sunday November 29, 2009 | Permalink
  2. checking it out now.. will post back soon.

    Posted 5 years ago on Sunday November 29, 2009 | Permalink
  3. Okay something is conflicting with Gravity Forms. The first thing we are going to need to have you do is determine what exactly is conflicting with it.

    You will need to do the following:

    - Activate the KUBRICK WordPress Theme, this is the default them. Then test the form on the front end to see if it submits. If it does submit, then your Theme (which appears to be Thesis) is conflicting with it.

    If activating the default theme results in the same issue we will need to determine if it is a Plugin conflict. To determine if it is a plugin conflict you will need to do the following:

    - Deactivate ALL other plugins except Gravity Forms

    - Activate each plugin one by one, checking to see if you can submit the form after each one you activate.

    When you hit a plugin that causes the form not to submit, that is the one that is causing a conflict.

    When you determine if it is a theme or a plugin, post in this thread with which theme or plugin is causing the issue (and the version if possible) and we can then look into why the conflict is happening.

    If you would like, we can do this for you but you would have to use the Contact Us form to send us a login for your WordPress site so that we could do this.

    Thanks,

    Carl

    Posted 5 years ago on Sunday November 29, 2009 | Permalink
  4. As for the notifications, have you setup your Notification emails? These aren't on by default, you have to set them up for each form.

    Posted 5 years ago on Sunday November 29, 2009 | Permalink
  5. Hi Carl,

    Thanks for this. I have set my notifications for each contact form but I haven't yet tried your fixes suggested above. I will try them out and then get back to you on my success. Thanks so much for the help.

    Tara

    Posted 5 years ago on Tuesday December 1, 2009 | Permalink
  6. Hi Carl,

    Bad news, I deactivated all plugins (except Gravity) and tried submitting and no luck. Then I switched over to the Kubrick theme, with all plugins deactivated (except Gravity), and tried submitting a message and again, no luck.

    Any other thoughts as to why can't I get this bloody thing to work?

    Thanks,

    Tara

    Posted 5 years ago on Wednesday December 2, 2009 | Permalink
  7. Can you give us a WordPress login to this site so we can check it out and debug the issue?

    Use the Contact Us form to submit the information and we will look into it more closely so we can determine the issue.

    Posted 5 years ago on Wednesday December 2, 2009 | Permalink
  8. Sure, Carl. To what email address should I send my login info?

    Posted 5 years ago on Wednesday December 2, 2009 | Permalink
  9. Tara, you can just send the info via the contact form and we'll get it.

    http://www.gravityhelp.com/contact-us/

    thanks

    Posted 5 years ago on Wednesday December 2, 2009 | Permalink
  10. Hello, just following up on this issue... were you able to determine why the form is not working on my site?

    Posted 5 years ago on Wednesday December 9, 2009 | Permalink
  11. Sorry to be impatient but I would very much like to get this form working on my site. Any help that could be provided would be awesome... thank you.

    Tara Joyce

    Posted 5 years ago on Thursday December 10, 2009 | Permalink
  12. I'm wondering if this could be the issue... I wanted to remove the /index.php/ from my WordPress site URL so I had my host had to figure out a URL Mod-Rewrite Workaround for IIS 6.0 and Wordpress. I wonder if that could be affecting the submission of the form?

    Posted 5 years ago on Thursday December 10, 2009 | Permalink
  13. The form not submitting is probably URL rewriting related. It's definitely a server configuration issue that is preventing the form from submitting to itself. Hosting PHP based sites on IIS is usually a recipe for problems. Who is your web host?

    Posted 5 years ago on Thursday December 10, 2009 | Permalink
  14. MetaWave Digital Media out of Toronto - http://www.meta-wave.com/

    What should my next steps be to get this working?

    Oh and Carl, I keep subscribing to this thread but I never get emailed your responses... not sure why.

    Posted 5 years ago on Friday December 18, 2009 | Permalink
  15. I'll check on the forum notification plugin and see what's up. Thanks for the note about that. You can always favorite this topic and then keep an eye on it via the rss feed

    http://forum.gravityhelp.com/rss/profile/elasticmind

    Posted 5 years ago on Friday December 18, 2009 | Permalink
  16. Thanks, Kevin. Can you help me with the issue with my form? I'd really like to get this thing to work and I'm unsure what my next steps should be.

    Posted 5 years ago on Friday December 18, 2009 | Permalink
  17. Try this. Go to your permalinks settings for this site and temporarily change it so that this site is using the default permalink setting. It should look like this:

    Ex.
    http://www.elasticmind.ca/?p=123

    Now go to your Contact page and submit the form. It will work.

    Your web host or specific hosting account has something going on with the URL rewriting that is preventing the form from submitting to itself. This is why it works if you have your permalinks setup to use ?p=XXX instead of the page name.

    You are going to have to contact your host to try and determine the issue.

    Your site also has issues as you can't login to the admin without going to a specific page within the admin. Just going to /wp-admin and logging in doesn't work. This could very well be related.

    If they are unable to assist you I would strongly consider switching hosts, you shouldn't be having these problems with your permalinks. We have customers on all different web hosts and nobody else is experiencing this issue... we can recommend a good web host if you would like.

    Posted 5 years ago on Friday December 18, 2009 | Permalink
  18. Carl,

    Thanks so much for the response and information. I will chat with my host about the issue.

    Much appreciated,

    Tara

    Posted 5 years ago on Friday December 18, 2009 | Permalink
  19. Hi, Carl!
    I finally got the plugin working and loved it but when I submitted the form it erased the entire thing! So frustrating. I know it's going to be great, but I also need to know it will save.
    I am using PHP5, Wordpress Version 2.9.
    Help!

    Posted 5 years ago on Monday December 21, 2009 | Permalink
  20. Hit us up via the Contact Us form with details. The issue the user that started this thread is having is unrelated to the issue you are encountering which is unique.

    The form submission does nothing that would cause it to erase the entire thing so something else is going on.

    If you can, include a WordPress login for the site you have this installed in when you submit the Contact Us form so we can login and debug the issue.

    Posted 5 years ago on Monday December 21, 2009 | Permalink
  21. breslincenter
    Member

    Hi,

    I am having an issue with my form not submitting AND with email notification not being sent. My form URL is: http://beckersbridal.com/?page_id=210

    The host is GoDaddy (Windows).

    When I deactivate permalinks, it submits (but no email is sent out, and I have verified the email settings). When permalinks are activated, (which I need), the form will not submit... it just refreshes the page to the blank form again.

    I had issues with GoDaddy and permalinks before realizing the form issues, so I uploaded a file titled 404-handler.php to my site that I found on another forum. Here is the code:

    <?php
    // This is the default file for the site. Usually index.php
    $default = 'index.php';
    
    // The name of this file.
    // Set this value for the URL in Custom Error Properties of your website in IIS.
    // Goto: IIS Manager > Websites > [Site Name] > Properties > Custom Errors >
    // 404 & 404;2 & 404;3 > URL (Requires a '/' prefix in IIS).
    $thisfile = '404-handler.php';
    
    $_SERVER['ORIG_PATH_TRANSLATED'] = str_replace($thisfile, $default, $_SERVER['ORIG_PATH_TRANSLATED']);
    $_SERVER['SCRIPT_FILENAME'] = str_replace($thisfile, $default, $_SERVER['SCRIPT_FILENAME']);
    $_SERVER['ORIG_PATH_INFO'] = str_replace($thisfile, $default, $_SERVER['ORIG_PATH_INFO']);
    $_SERVER['SCRIPT_NAME'] = str_replace($thisfile, $default, $_SERVER['SCRIPT_NAME']);
    $_SERVER['PHP_SELF'] = str_replace($thisfile, $default, $_SERVER['PHP_SELF']);
    $_SERVER['PATH_INFO'] = false;
    
    $qs =& $_SERVER['QUERY_STRING'];
    $ru =& $_SERVER['REQUEST_URI'];
    $pos = strrpos($qs, '://');
    $pos = strpos($qs, '/', $pos + 4);
    $_SERVER['URL'] = $ru = substr($qs, $pos);
    $qs = trim(stristr($ru, '?'), '?');
    
    // Required for WordPress 2.8+
    $_SERVER['HTTP_X_ORIGINAL_URL'] = $ru;
    
    // Fix GET vars
    foreach ( $_GET as $var => $val ) {
      if ( substr($var, 0, 3) == '404') {
        if ( strstr($var, '?') ) {
          $newvar = substr($var, strpos($var, '?') + 1);
          $_GET[$newvar] = $val;
        }
        unset($_GET[$var]);
      }
      break;
    }
    include($default);
    ?>
    Posted 3 years ago on Friday July 1, 2011 | Permalink
  22. @breslincenter The problem is WordPress permalinks don't work well on older versions of IIS on Windows. 404 rewrite handlers are hacks and don't work properly. Can you switch your hosting to use Linux? Hosting WordPress and PHP apps on Windows hosting is a recipe for problems, the majority of which are related to Permalinks and Email issues with WordPress.

    Posted 3 years ago on Friday July 1, 2011 | Permalink

 

Support Tickets

Open A New Support Ticket
 Open A New Priority Support Ticket *

* Developer license holders only