Please Note: We are no longer using forums to facilitate standard support. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Form Not Submitting!

  1. brent
    Member

    For some reason my forms are not submitting on my production website:

    http://cavendersranch.com/fun/contests/back-to-school-boot-bash/

    The page just refreshes to an empty form.

    Posted 5 years ago on Monday August 2, 2010 | Permalink
  2. It's hard to tell what the problem could be. I don't see a Javascript error so that rules out a Javascript issue. It's one of three things:

    - Theme Conflict

    If it's a Theme Conflict you can test for this by activating the Default Theme (2010 on WordPress 3.0 or Kubrick on WordPress 2.9) and then testing the form. If it submits, then that shows something in your theme is preventing the form from submitting properly.

    - Plugin Conflict

    If it's a Plugin Conflict you can test for this by deactivating ALL of your plugins and then only activating the Gravity Forms plugin and then testing the form. If it submits, then it's a plugin conflict and you can then activate each of your other plugins one by one and try submitting the form after each one until you run into the plugin that causes the issue to happen.

    - Form Setup Issue

    The only time we have seen this happen is when the user has a form field set to Visibility Admin Only (advanced field setting) but also set as required. The issue that would happen is the field would be required and fire validation but since the field isn't shown on the front end... no error was shown. If the field is set to Admin Only it should not be set to Required.

    Posted 5 years ago on Monday August 2, 2010 | Permalink
  3. brent
    Member

    I have verified that it is not a Theme Conflict. There are also no hidden fields. Does is matter that my <form> tag has no action defined:

    <form action="" class="" id="gform_2" enctype="multipart/form-data" method="post">

    Posted 5 years ago on Monday August 2, 2010 | Permalink
  4. The form submits to itself, so no action is present. Like I said, it's one of the 3 things above. So you will have to check for possible plugin conflicts or if you have any admin only fields that are set to required.

    Admin Only fields aren't hidden fields. They don't appear on the form at all on the frontend. It's a setting on a field.

    If none of the above debugging turns out anything we can look into it further but you would have to supply us with a WordPress admin login (via our Contact Us form) so we could take a look at your form setup and run a test.

    What happens when you Preview a form and try submitting it? (Go to Edit Forms, hover over a form and select Preview)

    Posted 5 years ago on Monday August 2, 2010 | Permalink
  5. brent
    Member

    It successfully submitted the form when in Preview mode. So does that make you think even more that it is a plugin conflict?

    Posted 5 years ago on Monday August 2, 2010 | Permalink
  6. Yes. It makes me think it is a theme or plugin conflict. Something on the front end is interfering with the form submitting. Since you ruled out a theme conflict (if you did that test) then it must be a plugin conflict.

    Posted 5 years ago on Monday August 2, 2010 | Permalink
  7. brent
    Member

    I am working through deactivating plugins, but not having much luck so far. Are there any known conflicts?

    Posted 5 years ago on Monday August 2, 2010 | Permalink
  8. The Headspace2 plugin sometimes conflicts. I say sometimes because comes and goes as the developer of that plugin makes changes. It's a frequently offender of causing plugin conflicts with Gravity Forms and many other plugins. Thats the main culprit I can think of right now and i've never seen this happen with any other plugins.

    If you can't determine what the issue is, contact us via our contact us form and send us a WordPress admin login and we can take a look at the site.

    Posted 5 years ago on Monday August 2, 2010 | Permalink
  9. brent
    Member

    Just sent message via your contact form.

    Posted 5 years ago on Monday August 2, 2010 | Permalink
  10. has this been solved? i am having a similar issue (exactly the same actually) - i set my theme to twentyten - disabled all plugins but still don't have a submit on the live site - my preview works as well.

    here is the url
    http://nohotwire.com/about-ravelco/request-quote/

    Posted 5 years ago on Wednesday August 4, 2010 | Permalink
  11. His issue is a permalink issue related to hosting on IIS. He is working with host to figure out what is going on, his host was GoDaddy and they made changes to his URL rewriting that is causing this issue.

    When the page is accessed via page id (ex. http://domain.com/index.php?p=XX) the form submits fine. The preview works fine. However something is wrong with his permalink or url rewriting on his server that is causing the form not to submit to itself.

    Are you also using IIS? On GoDaddy?

    Posted 5 years ago on Wednesday August 4, 2010 | Permalink
  12. it is on godaddy but not IIS - it's a linux account.

    Posted 5 years ago on Wednesday August 4, 2010 | Permalink
  13. If you send us a WordPress admin login via our Contact Us form I can take a look. GoDaddy is hands down the single biggest source of server configuration related conflict issues we run into on a regular basis.

    Posted 5 years ago on Wednesday August 4, 2010 | Permalink
  14. Why does this page return a 404 error but still display content?

    http://nohotwire.com/about-ravelco/request-quote/

    Date: Wed, 04 Aug 2010 19:25:24 GMT
    Server: Apache
    X-Pingback: http://nohotwire.com/xmlrpc.php
    Keep-Alive: timeout=15, max=97
    Connection: Keep-Alive
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=UTF-8
    
    404 Not Found

    http://www.google.com/search?q=godaddy+wordpress+404

    Posted 5 years ago on Wednesday August 4, 2010 | Permalink
  15. That is odd. The page is returning as a 404 but yet it is returning the WordPress page content and acting as if nothing is wrong. I didn't notice that until I inspected the page further using FireBug.

    This is why the form won't submit properly. Some strange server configuration issue going on for sure. Not sure why GoDaddy does the things that they do with their server configurations. Always a source of issues.

    @webhank You need to get in touch with GoDaddy and determine why your pages appear to be working but are actually returning as a 404 to the browser.

    If you have FireBug for FireFox you can see this information by viewing the page using FireFox, turning on FireBug go to the Net tab and then choose All. It's like illinoisharley says above, it's returning a 404 Not Found. Odd.

    Posted 5 years ago on Wednesday August 4, 2010 | Permalink
  16. I have seen a few postings for this, but none that provided a viable answer for me.

    I am running Wordpress on a Windows 2008 server, running IIS7. All permissions look fine with my install. All pages come up fine, etc.

    You can see it at: http://www.greatersba.org/

    But when I try to PREVIEW the form, it's trying to go to:
    http://www.greatersba.org/wp-content/plugins/gravityforms/preview.php?id=1

    And I get a 404 File or Directory not found error message.

    Some of the 'header' information (when I use Firebug to see the issue) says:

    Cache-Control no-cache, must-revalidate, max-age=0
    Pragma no-cache
    Content-Type text/html
    Expires Wed, 11 Jan 1984 05:00:00 GMT
    Last-Modified Sat, 16 Oct 2010 13:39:10 GMT
    Server Microsoft-IIS/7.0
    X-Pingback http://www.greatersba.org/xmlrpc.php
    X-Powered-By ASP.NET
    Date Sat, 16 Oct 2010 13:39:09 GMT
    Connection close
    Content-Length 1245

    What can I do to correct this issue?

    I am hosting the site on a VPS (and I have remote desktop access to the server).

    The file xmlrpc.php does exist in the root of my site.

    Please tell me what I can do to resolve this.

    Again .. everything else on my site is working fine. What is it about Gravity Forms that is different and not using permalinks (like the rest of my site)??

    Thanks,
    Gary Gordon

    Posted 4 years ago on Saturday October 16, 2010 | Permalink
  17. JUST A FOLLOW UP NOTE

    1. I disabled all of my plugins, and re-tested, but it still didn't work.

    2. I set my Permalinks to the default option, and the Preview in Gravity Forms worked fine.

    3. But when I set my Permalinks to "custom" and set them to /%category%/%postname%/ ... it looks like it's not using it.

    I guess what I don't understand is .. the "custom" Permalinks (of /%category%/%postname%/) works with everything else in my Wordpress site. But Gravity Forms isn't. So, it appears that Gravity Forms is not working in the same way that Wordpress is, with the way it creates and identifies it's Permalinks. Since my "custom" Permalinks of /%category%/%postname%/ works fine with my Wordpress pages, categories, posts, etc., I'd appreciate it if someone could help me figure out why Gravity Forms isn't using this in the same way? It should ... shouldn't it????

    Thanks,
    Gary

    PS: Again, I am on a Windows 2008 server, running IIS7.

    And, my web.config file has the following rewrite code in the file:

    <rewrite>
    <rules>
    <rule name="Main Rule" stopProcessing="true">
    <match url=".*" />
    <conditions logicalGrouping="MatchAll">
    <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
    <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
    </conditions>
    <action type="Rewrite" url="/index.php" />
    </rule>
    </rules>
    </rewrite>

    Posted 4 years ago on Saturday October 16, 2010 | Permalink
  18. ONE MORE UPDATE (*smile*

    I tested changing my PERMALINKS.

    It was set to: /%category%/%postname%/

    (Using this was fine for all my pages, posts, etc., in my Wordpress installation.)

    But .. it was causing Gravity Forms to fail, for the PREVIEW.

    So, I changed it to /%postname%/

    And .. now it works.

    There appears to be something within Gravity Forms that doesn't like the /%category%/%postname%/ PERMALINKS.

    Is this something Gravity Forms can update, correct, or what ever you might want to call it.

    I'd like to be able to use /%category%/%postname%/ and not just /%postname%/ for the PERMALINKS custom setting, or anything other than just one permalink.

    If I am doing something wrong, in using /%category%/%postname%/ .. please let me know. I'll be happy to make a change that you deem appropriate. Thanks.

    Please let me know.

    Thanks,
    Gary

    Posted 4 years ago on Saturday October 16, 2010 | Permalink
  19. @garymgordon The users issue you are adding to is unrelated. They were having a problem with the form submitting, you are having a problem with the preview itself. Two different issues.

    Also please be sure to create a new post for your issue rather than replying to an older post as sometimes older posts can get overlooked if the original customers issue has already been resolved. Sometimes resolution takes place outside of the forum.

    I have responded to your requests via email with instructions on what to do to determine the problem. It is most likely a server configuration issue and I sent you some steps you will have to take to determine what it is.

    Posted 4 years ago on Saturday October 16, 2010 | Permalink
  20. i am having same issues with the custom permalinks, it would be helpful to know what was changed here to fix his issue.

    Posted 4 years ago on Thursday October 21, 2010 | Permalink
  21. @c9labs The permalink issue is typically an issue with Windows hosting and how IIS handles URL Rewriting. I haven't heard back from this user with what the resolution was. Are you hosted on a Windows server? Running WordPress on a Windows server is typically a recipe for issues.

    Posted 4 years ago on Friday October 22, 2010 | Permalink

 

Support Tickets

Open A New Support Ticket
 Open A New Priority Support Ticket *

* Developer license holders only