Please Note: We are no longer using forums to facilitate standard support. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Form submit, no entry in database

  1. Hello

    I have a form set up that successfully validates and submits, but when I check the form entries within WP, it just says "entries 0", and the email that fires off contains no data - just blank.

    Any ideas what could be going on here?

    Running WP 3.3


    Posted 3 years ago on Friday January 13, 2012 | Permalink
  2. OK so when I roll back to Gravity Version my form entries appear, but when I upgrade to the latest version of Gravity, they disappear.

    Any ideas as to why this happens?


    Posted 3 years ago on Monday January 16, 2012 | Permalink
  3. sheilabergman

    Same Problem here.

    Posted 3 years ago on Monday January 16, 2012 | Permalink
  4. NYTS

    Same issue here... how do I roll back to an earlier version?

    Posted 3 years ago on Thursday February 9, 2012 | Permalink
  5. There aren't any known issues with the current public release as it relates to what is described here and i'm not sure why there was not a response to this forum post. There also hasn't been a follow up from the other 2 users above.

    Because there aren't any known issues we'd need to investigate this by debugging the issue on a site that is experiencing it. Rolling back to an earlier version is not the solution. My gut tells me this is a PHP memory issue. When a site runs out of PHP memory it will start to do all kinds of strange things such as partial page loads, etc.

    Send us the URL of the site, a WordPress admin login and an FTP login for the site via our Contact Us form and reference this forum post when doing so and we can take a look at your site and determine exactly what is going on.

    Posted 3 years ago on Thursday February 9, 2012 | Permalink
  6. I just realized after reviewing this issue again that you mentioned you tried rolling back to Gravity Version which is a very old version. Based on that I know what the issue is.

    The latest version of Gravity Forms has database related changes that it needs to make. If those changes aren't made, then you will encounter issues similar to what you described (blank emails).

    The issue is the database user configured in your wp-config.php file does NOT have the necessary permissions to alter the database and add additional columns to the Gravity Forms tables.

    You need to correct the database user configured in your wp-config.php file so that it has the correct permissions to be able to make the necessary database table updates.

    How do you know if this is happening to you?

    - Go to the Settings page of Gravity Forms (Forms > Settings)

    - Once on the Settings page, in the url address bar append &settings to the end of the web site address and hit enter.

    For example instead of this:

    Change it to this:

    That will attempt to execute the setup routine again and if the database changes can't be made, it will return errors directly on the page that will say exactly that.

    In the case of @NYTS, who supplied me an admin login to his site, that is exactly what happens. See this screenshot:

    In this situation you need to fix the database user so it has the correct permissions. Then after doing so, repeat the steps above and go to the Settings page and append &setup to the end of the URL. This will again re-run the necessary setup and attempt the changes again. If the database user has the correct permissions, the changes will be made and no errors will be displayed.

    Posted 3 years ago on Friday February 10, 2012 | Permalink
  7. pjc

    I also just lost all my form entries on updating to the latest version. They still seem to be there, because the entries page says "displaying 1 of 17" but nothing appears in the entries pages. To my client it just looks as though all of the hundreds of entries are gone.

    This fix you mention doesn't seem to apply to me. The database user has full permissions. When I enter the setup URL you suggested I don't get a "denied to user" error. I get this:

    WordPress database error: [Table '94rvLt_rg_form' already exists]
    CREATE TABLE 94rvLt_rg_form ( id mediumint(8) unsigned not null auto_increment, title varchar(150) not null, date_created datetime not null, is_active tinyint(1) not null default 1, PRIMARY KEY (id) ) DEFAULT CHARACTER SET utf8

    Suggestions? Do I have to restore the site database using the old version of GF?

    Posted 3 years ago on Saturday February 11, 2012 | Permalink

This topic has been resolved and has been closed to new replies.

Support Tickets

Open A New Support Ticket
 Open A New Priority Support Ticket *

* Developer license holders only