Please Note: We are no longer using forums to facilitate standard support. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Freshbooks add-on CURLOPT_FOLLOWLOCATION warning

  1. antonsamper
    Member

    Hi guys, every time i go to create a new feed i see the following error:

    Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /PATHTOWP/wp-content/plugins/gravityformsfreshbooks/api/HttpClient.php on line 79

    Is there a way to fix this?

    Posted 4 years ago on Sunday July 24, 2011 | Permalink
  2. You will need to discuss this with your web host. They need to disable safe_mode on your site, otherwise the FreshBooks API wrapper won't work.

    Posted 4 years ago on Monday July 25, 2011 | Permalink
  3. antonsamper
    Member

    thanks i'll speak to the server guys

    Posted 4 years ago on Wednesday July 27, 2011 | Permalink
  4. I am having the same problem. I have disabled safe_mode, double checked that it is off on php.info but am still getting this error: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in ....com.au/html/wp-content/plugins/gravityformsfreshbooks/api/HttpClient.php on line 79
    It also appears above a normal contact form when submitted. Please Help!

    Posted 3 years ago on Friday November 4, 2011 | Permalink
  5. It appears that PHP does not know it was disabled. Did you have to restart the web server or anything, to ensure that it's no longer present in the phpinfo()?

    That error is coming from PHP and it's complaining about safe_mode being on, or open_basedir being set.

    Posted 3 years ago on Friday November 4, 2011 | Permalink
  6. I fixed the problem: both safe_mode and cURL have to be disabled. I added the following to my php.ini file:

    safe_mode = Off
    open_basedir = none ; /nfs:/tmp:/usr/local:/etc/apache2/gs-bin:/usr/bin/convert

    allow_url_fopen = On

    memory_limit = 100M
    cgi.fix_pathinfo=1

    Posted 3 years ago on Sunday November 6, 2011 | Permalink
  7. Very good. Thanks for the update and for posting the solution for others.

    Posted 3 years ago on Tuesday November 8, 2011 | Permalink

This topic has been resolved and has been closed to new replies.

Support Tickets

Open A New Support Ticket
 Open A New Priority Support Ticket *

* Developer license holders only