Please Note: We are no longer using forums to facilitate standard support. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Gravity Forms v1.5 BETA 2 - Date picker not showing up

  1. gazdev
    Member

    I've added a date picker to my multi-page form, but what shows on the generated form is a date field.

    Any ideas?

    Posted 4 years ago on Friday November 19, 2010 | Permalink
  2. The datepicker.js script isn't being loaded. Check to make sure your theme has the wp_footer() function in your footer. php file. That's required to load the necessary scripts.

    Posted 4 years ago on Friday November 19, 2010 | Permalink
  3. gazdev
    Member

    Of course. Thanks!

    Posted 4 years ago on Friday November 19, 2010 | Permalink
  4. rengelman
    Member

    Hi Kevin,

    I am having the same problem but I dont know much about messing with the code. Would you be able to explain how to do this for the technically chalenged?

    Thank you,

    Ron

    Posted 4 years ago on Tuesday November 23, 2010 | Permalink
  5. @rengelman This WordPress documentation page has details on where the wp_footer() and wp_head() function calls go in your theme:

    http://codex.wordpress.org/Theme_Development

    The wp_footer() function call goes in your themes footer.php file and the wp_head() function call goes in your themes header.php file.

    Posted 4 years ago on Tuesday November 23, 2010 | Permalink
  6. latinguy2004
    Member

    I'm having the same issue but I'm using 1.5.rc2.5.

    I made sure wp_footer() function call was in footer.php and when I view source on the page I see that datepicker.js seems to be loading.

    Am I doing anything wrong?

    Here's the page where the form is at http://www.koshgarianrugcleaners.com/schedule-online/

    Posted 4 years ago on Wednesday January 5, 2011 | Permalink
  7. @latinguy2004 The issue is you have a Javascript error because your theme is loading jQuery twice. jQuery is loaded once by your theme, as is standard for WordPress themes, and then something else on your site is loading jQuery again from a 3rd party.

    This is the line of code in your theme causing the issue:

    <script type="text/javascript" src="http://www.instantslideup.com/2.0/isu/resource/jquery.js"></script>

    So it's related to the instantslideup code you have on your site. Anytime you include jQuery twice on a page it can cause issues and errors, as is the case here.

    Posted 4 years ago on Wednesday January 5, 2011 | Permalink
  8. latinguy2004
    Member

    Awesome thanks for the fast response. I removed that line from the code and it worked fine.

    Posted 4 years ago on Wednesday January 5, 2011 | Permalink
  9. First of all, Gravity Forms rocks! One of the best investments I've made in the last couple years.

    Secondly, on my date picker problems: I have the same problem - date picker not loading. I checked the footer and identified that the code indicated is there: <?php woo_footer(); ?>

    However, there was another line after it: <?php woo_foot(); ?>, which I removed. Still no date picker. What am I missing?

    http://keithcoury.com

    Posted 4 years ago on Friday May 20, 2011 | Permalink
  10. Sorry, the date picker should be seen on the form on this page: http://keithcoury.com/schedule/.

    I also have heard back that the form displays differently/incorrectly in Safari - post this topic separately?

    Posted 4 years ago on Friday May 20, 2011 | Permalink
  11. I'm not sure what functions you are referring to as far as woo_footer(), the function we referenced above is wp_footer() which is not the same as woo_footer(). I'm assuming this is a WooTheme you are using, which WooTheme is it?

    Posted 4 years ago on Friday May 20, 2011 | Permalink
  12. This is actually what is there now:
    </div><!-- /#wrapper -->
    <?php wp_footer(); ?>
    <?php wp_foot(); ?>

    </body>
    </html>

    I don't see the code I pasted earlier with woo in it.

    Posted 4 years ago on Friday May 20, 2011 | Permalink
  13. Are you displaying this form using a Widget in a Sidebar on your form? If so, make sure that that widget is set to output scripts, you may have that option turned off in the widget which is why the scripts are being output. If you aren't using the Widget, how are you displaying the form? Shortcode or function call?

    Posted 4 years ago on Friday May 20, 2011 | Permalink
  14. Hi Carl -
    I've been reading the other posts and realized the issue is with the scripts. I am using the Gravity Forms Widget. So, how do I set the scripts in the widget properly? I've read the documentation but just don't know where to add this (with the right form id, etc:

    <?php
    2 gravity_form_enqueue_scripts($form_id, $is_ajax);
    3 ?>

    Posted 4 years ago on Friday May 20, 2011 | Permalink
  15. The Wootheme is Kaboodle, by the way.

    Posted 4 years ago on Friday May 20, 2011 | Permalink
  16. If the Widget has the option turned on (which it is by default) it should output the necessary scripts automatically. Did you check in your Widget settings to make sure the output scripts option is NOT checked? If it's checked then that is probably the problem. See this screenshot: http://grab.by/abeq

    Posted 4 years ago on Friday May 20, 2011 | Permalink
  17. Here's what I see on my widget settings:
    http://keithcoury.com/widget-screenshot/

    No advanced settings area?

    Posted 4 years ago on Friday May 20, 2011 | Permalink
  18. That isn't the Gravity Forms widget, it appears you are using a 3rd party Widget, possibly Joost de Valk's (Yoast.com) widget. You need to use the Gravity Forms official widget, it will appear as just "Form" in your list of Widgets and will have the options that appear in my screenshot.

    Posted 4 years ago on Friday May 20, 2011 | Permalink
  19. Yes, I did use Joost de Valk's (Yoast.com) widget. I didn't know there was an official widget.

    Posted 4 years ago on Friday May 20, 2011 | Permalink
  20. Thank you!!!! Thank you!!! Works perfectly with the official widget.

    Posted 4 years ago on Friday May 20, 2011 | Permalink
  21. And the official widget appears to have fixed the Safari formatting issue!

    Posted 4 years ago on Friday May 20, 2011 | Permalink
  22. Good to hear! Glad that resolved the issue for you.

    Posted 4 years ago on Friday May 20, 2011 | Permalink

This topic has been resolved and has been closed to new replies.

Support Tickets

Open A New Support Ticket
 Open A New Priority Support Ticket *

* Developer license holders only