Please Note: We are no longer using forums to facilitate standard support. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Incorrect Name field in email and AWeber

  1. Hi,

    I use WordPress MultiSite and any email sent to me comes from the URL of my main site on WordPress and not the Name field of the form as selected.

    Plus, even worse, when you integrate with AWeber it uses your main site name as the name of the person in your list. So whenever anyone is added, they all have the same name that is the URL of my main website.

    A fix would be great, thanks!

    Posted 3 years ago on Thursday December 1, 2011 | Permalink
  2. This is either going to be caused by another plugin or theme manipulating the wp_mail() function in WordPress and changing the Send From, or it's going to be a web server configuration issue that is changing the Send From after wp_mail() asks the server to send the email.

    Gravity Forms passes whatever you configure in the Notifications to the wp_mail() function to send the email. After that, it's out of Gravity Forms control. If a plugin or theme has filtered the wp_mail() function in such a way that it's hardcoding or changing values, or if the server is doing things after the function is executed there isn't anything Gravity Forms can do about it.

    What I would suggest doing is testing for plugin and theme conflicts. Here is information on how to do that:

    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    If that turns up nothing, you could try discussing this with your web host.

    It's possible your web host doesn't allow you to set the Send From to an email address that isn't associated with that web site hosting account and then automatically changes it before sending the email.

    We had sites hosted on BlueHost a couple years ago and encountered a similar issue and it was BlueHost changing the Send From address because it was not a From address that was associated with the web site itself.

    The existing AWeber Add-On requires us to integrate with AWeber by effectively spoofing the users name and email when sending an email because the AWeber API did not support adding new subscribers via an API call when the AWeber Add-On was created.

    The good news is AWeber launched a new version of their API last week and we will be updating the AWeber Add-On soon to take advantage of the new capabilities. This will allows us to add the new subscriber via an API call, which is much more reliable and bulletproof than the email method being used now. The other benefit is we'll be able to enhance the AWeber Add-On to support custom fields like we do with MailChimp and Campaign Monitor.

    Posted 3 years ago on Thursday December 1, 2011 | Permalink
  3. Hi Carl,
    Many thanks for getting back to me. I've tested my plugins and theme and it works the same with only Gracity Forms (and AWeber addon) active in the Twenty Ten theme.

    In the past I've used Contact Form 7 and Dagon Design Form Mailer (currently on my site) and neither have this problem.

    Good news about AWeber, I can't use my form until the problem above is fixed, but that sounds like that would work even without the problem above. As I don't really care when emails come to me from the wrong name but adding them to the list with the wrong name is not something I want to do.

    I'll speak to my web host and update here. Thanks for the quick reply.

    Posted 3 years ago on Thursday December 1, 2011 | Permalink
  4. Let me know what your host says. The issue could be related to spoofing someone else's email address, it's likely your web server doesn't like this and it's changing the send from rather than allowing you to use their servers to spoof someone else's email address via the custom Send From.

    As I mentioned, Gravity Forms uses the standard WordPress wp_mail() function, so it doesn't bring it's own email function into the equation and doesn't do anything unusual with how it sends email. So any issues are going to be outside influences causing the problem to occur.

    Posted 3 years ago on Friday December 2, 2011 | Permalink
  5. Hi Carl,

    So after lengthy chats with my host (HostGator) and being escalated a couple of times it turns out they're not blocking anything. They used different plugins (mentioned before, which work fine) and they did their own test directly spoofing name and email and all worked. This is what they finally said:

    "Our servers have not blocked the ability to change the From: headers on outbound email. I have verified from your account the ability to send an email using a custom 'From Name' as well as custom 'From Email'. I have sent a test one to your email addresses from the name 'Host Gator Test' and the email 'notreallyfrom@hostgator.com'. [I received this and it worked fine]

    This is not a server issue, it is a plugin issue that is not coded to properly adjust the correct headers, as our servers will use your cpanel@servername as the default if it has not been set in the email. "

    I can send you the headers of one of the non-working and of the working emails privately if you like?

    Let me know what you think and if you need access or anything to further investigate. Very much appreciated!

    Posted 3 years ago on Friday December 2, 2011 | Permalink
  6. Hey Guys just wanted to chime in and say I'm having the same issue and am on Hostgator as well.

    Posted 3 years ago on Saturday December 3, 2011 | Permalink
  7. Hi Carl - is there any update on this? It seems several WordPress MS/MU people are having the same problem. I know you say it's the host but after over an hour with their different levels of support they say it's not.

    If it can't be fixed somehow the plugin is not going to be any good for me.

    Thanks

    Posted 3 years ago on Wednesday December 7, 2011 | Permalink
  8. Joel, can you provide links to a couple of the topics you mentioned re WMPS/WPMU? Thanks.

    Posted 3 years ago on Wednesday December 7, 2011 | Permalink
  9. Thanks Chris.

    There's jayohare above in this thread (http://www.gravityhelp.com/forums/topic/incorrect-name-field-in-email-and-aweber#post-43034) and also here:
    http://www.gravityhelp.com/forums/topic/main-sites-name-sent-as-from-name-in-notifications

    I'm sure I found one other when I was initially researching this but I can't find it at the moment.

    I know it may be a host problem even though they say insist over several conversations and lots of time that it's not but I can't use the plugin if it's not fixable so will have to get a refund unfortunately (if one is even offered).

    I would understand more if the Name AND email address could not be spoofed, but the email address is fine it's just the From Name being taken from the main site URL in WordPress MU/MS.

    Thanks for your help. If anyone needs access or any information I'd be happy to help.

    Posted 3 years ago on Wednesday December 7, 2011 | Permalink
  10. Hi Joel,

    I'd like to help you figure this out. If you don't mind, could you send me a WP login and FTP access to your site? I'll jump in tomorrow morning and take a peek.

    Send to david@rocketgenius.com.

    Posted 3 years ago on Thursday December 8, 2011 | Permalink
  11. Thanks for the offer David, I've emailed you. Much appreciated!

    Posted 3 years ago on Thursday December 8, 2011 | Permalink
  12. Just to let everyone know, David fixed this for me. It was a core MU plugin called New Blog Defaults - http://wordpress.org/extend/plugins/wpmu-new-blog-defaults/

    He added a file called network_custom.php to my theme folder that contained

    <?php remove_filter('wp_mail_from_name', 'cets_nbd_from_name'); ?>

    Which fixed it. Genius!

    Or removing the New Blog Defaults plugins will solve it too.

    Thanks for all your help, much appreciated!

    Posted 3 years ago on Friday December 9, 2011 | Permalink
  13. Thank you for the update. It's hard to predict where the plugin conflicts will come from sometimes.

    Posted 3 years ago on Saturday December 10, 2011 | Permalink

This topic has been resolved and has been closed to new replies.

Support Tickets

Open A New Support Ticket
 Open A New Priority Support Ticket *

* Developer license holders only