Please Note: We are no longer using forums to facilitate standard support. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

No entries recorded, Empty emails

  1. I'm working on a site with Yahoo web hosting (ugh!!) and am having problems with notification emails. I've noticed a few problems:

    1. Emails are being sent with no data included.
    2. The From and Email fields is from Administrator and not from the Data Fields requested within the form settings.
    3. No entries are being recorded.

    I'm assuming this is a problem with the Yahoo web host settings. Any ideas?

    Posted 3 years ago on Wednesday November 16, 2011 | Permalink
  2. This is going to be a problem with Yahoo web hosting.

    Last I checked Yahoo's web hosting did not even support PHP5 which means you couldn't even run Gravity Forms. So i'm not surprised they are having major issues.

    If entries aren't being stored it sounds like it could be possible that necessary database tables were not created.

    You will need to inspect the MySQL database for that site and make sure that the tables with the prefix rg_ exist. If they don't, then the database tables weren't created... most likely due to permissions related to the database user configured in your wp-config.php file.

    Posted 3 years ago on Wednesday November 16, 2011 | Permalink
  3. Amazingly, Yahoo has just updated their servers last week and I am now running PHP 5.3.6 and MySQL 5.1.55. Also, I checked the database and it looks like the necessary tables were created. (wp_gf_form ... wp_gf_test)

    Do you have any ideas on how to fix this?

    Posted 3 years ago on Wednesday November 16, 2011 | Permalink
  4. Do you know how to turn WordPress debug mode on? Edit your wp-config.php file, look for the wp_debug option and set it to true instead of false.

    Now go to your WordPress Dashboard and try previewing and submitting a form. See what errors occur and report back the errors you receive.

    Posted 3 years ago on Wednesday November 16, 2011 | Permalink
  5. Here is the error I see after submitting the form:

    WordPress database error: [Unknown column 'currency' in 'field list']
    INSERT INTO wp_rg_lead(form_id, ip, source_url, date_created, user_agent, currency, created_by) VALUES(1, '24.181.176.60', 'http://wainscotsolutions.com/beta/wp-content/plugins/gravityforms/preview.php?id=1', utc_timestamp(), 'Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:8.0) Gecko/20100101 Firefox/8.0', 'USD', 1)

    Here is an error code I saw when I first went into the Form Editor:

    WordPress database error: [Unknown column 'status' in 'where clause']
    SELECT form_id, count(id) as lead_count FROM wp_rg_lead l WHERE status='active' GROUP BY form_id

    Posted 3 years ago on Thursday November 17, 2011 | Permalink
  6. Your database isn't correct. You are missing columns in the Gravity Forms database tables. That is the problem.

    Was this a brand new Gravity Forms install or was this an existing install using an older version of Gravity Forms and then updated to Gravity Forms v1.6+?

    Posted 3 years ago on Thursday November 17, 2011 | Permalink
  7. The problem might be that I was using an older version of GF when the Yahoo Web Hosting was incompatible (mySQL 4). Then updated mySQL to v5 and then updated GF to v1.6. What do you think would be the next step?

    The site is still in development so I might we able to delete the GF tables and plugin and do a clean reinstall. Is this something I should do?

    Posted 3 years ago on Friday November 18, 2011 | Permalink
  8. Yes, I would suggest completely uninstalling Gravity Forms.

    You can do this by going to the Gravity Forms Settings page (Forms > Settings) and then choose the Uninstall option at the bottom of that page.

    Once uninstalled, verify that the Gravity Forms related tables have been deleted.

    Then re-install using the new version of Gravity Forms so that it is a clean install.

    Posted 3 years ago on Friday November 18, 2011 | Permalink
  9. I reinstalled/reset everything and now I have a different problem. Before the reinstall, I received empty emails, but now, after reseting GF, I don't receive any emails at all.

    I turned on WP Debug mode back on and I'm not receiving any errors with GF.

    Any ideas?

    Posted 3 years ago on Wednesday November 30, 2011 | Permalink
  10. I figured it out. It must be a problem with Yahoo's web hosting and their SMTP email. I installed the WP Mail SMTP plugin and had to use PHP mail with the SMTP information included.

    If anyone is using Yahoo web hosting, you have to make sure that the From Email on any form is set to an email account associated with your domain name.

    I hope this helps.

    Posted 3 years ago on Wednesday November 30, 2011 | Permalink
  11. @katart Good catch. Because your web server is what actually sends the emails, any strange configuration settings that they have implemented will have to be taken into account. Unfortunately there is no standard setup so it's difficult to provide a complete comprehensive list of things to look at for troubleshooting because things vary so greatly from host to host. We'll note this issue and the fix for future reference. Thanks!

    Posted 3 years ago on Wednesday November 30, 2011 | Permalink

This topic has been resolved and has been closed to new replies.

Support Tickets

Open A New Support Ticket
 Open A New Priority Support Ticket *

* Developer license holders only