Please Note: We are no longer using forums to facilitate standard support. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

PayPal Condition not Working Properly

  1. The PayPal Condition setting on the PayPal Transaction Settings page doesn't appear to be functioning the way I think it should.

    Here is the form:
    http://gqfoundation.org/jog-for-the-jugs-fun-run

    The condition is set so if the "I'll pay via PayPal / Credit Card right now." radio button is selected, then it should redirect to PayPal. This doesn't happen. If I un-check the PayPal Condition setting, it redirects to PayPal just fine with correct pricing, etc.

    Any thoughts as to why this is occuring?

    Am I missing something easy?

    Posted 4 years ago on Thursday April 21, 2011 | Permalink
  2. Try removing the slash in the radio button label "I'll pay via PayPal / Credit Card right now". I'm guessing that slash is what the problem is, the character is probably causing a problem.

    Posted 4 years ago on Thursday April 21, 2011 | Permalink
  3. Hello,
    Thanks for the quick response. That doesn't appear to have fixed it.

    Any more thoughts?

    Posted 4 years ago on Thursday April 21, 2011 | Permalink
  4. Without looking at your form and PayPal settings it's hard to tell. If you send us a WordPress admin login for this site via our Contact Us form we can take a look and see what is going on.

    Posted 4 years ago on Thursday April 21, 2011 | Permalink
  5. The issue was the single quote in the "I'll" portion of the text in that field. We will look into why this is causing an issue and get it corrected in an update to the PayPal Add-On.

    For now I have shortened the text for that field to remove that, and everything appears to be working as expected now.

    One thing I noticed is when you changed the form field value you didn't edit the PayPal Feed and update the conditional statement. So you removed the / from the field, but when you edit a conditional you then have to update wherever that conditional is used.

    Posted 4 years ago on Thursday April 21, 2011 | Permalink
  6. Thanks for the super quick response time. Also, thank you for adding what you sent via E-mail to the forum thread. Too many forum admins don't do that and leave threads unanswered!

    Posted 4 years ago on Thursday April 21, 2011 | Permalink
  7. My Form via PayPal isn't working. It doesn't even go to PayPal after hitting the submit button. URL is here:

    http://www.theblackownednetwork.com/blackownedphilly/associate-level-directory-submission/

    Posted 3 years ago on Tuesday January 17, 2012 | Permalink
  8. bizarro5, because every issue is unique, please begin a new topic for your issue and we will adress it there. It sounds like something is misconfigured. But please begin a new topic and we'll discuss it there individually. Thank you.

    Posted 3 years ago on Wednesday January 18, 2012 | Permalink

This topic has been resolved and has been closed to new replies.

Support Tickets

Open A New Support Ticket
 Open A New Priority Support Ticket *

* Developer license holders only