Please Note: We are no longer using forums to facilitate standard support. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Submit Button inline with single field.

  1. circus
    Member

    Hi there,

    I have a form with one field, no label, and a submit button. I want the field and the submit button to be inline similar to the screenshot here:

    https://skitch.com/abaloo/f6biw/homepage-proof-2.jpg

    ...so that together they take up the full width of the sidebar column, without any padding/margin between them.

    I have this working (apart fro some small pixel differences) on Safari, Firefox and Opera (all on Mac...Windows testing not yet begun) but for some reason not in Chrome.

    The site is at http://www.bloodredink.com and the form is at the bottom of the sidebar.

    Any help greatly appreciated.

    Many thanks,

    Ab

    Posted 3 years ago on Tuesday October 4, 2011 | Permalink
  2. Strange. It looks fine in Chrome to me. Are you sure something isn't cached?

    screenshot: http://bit.ly/ncYrjK

    Posted 3 years ago on Tuesday October 4, 2011 | Permalink
  3. circus
    Member

    Hey thanks for feedback.

    That is bizarre! Have emptied my cache and still displays wrong. Also now displaying wrong in Firefox. Can you please take a look in FF and have a look at the CSS? I have seen you given others great support on this issue elsewhere.

    Really appreciate feedback. Ab

    Posted 3 years ago on Tuesday October 4, 2011 | Permalink
  4. Yeah, looks fine in Firefox for me right now. You might do better by repositioning/floating the form footer div rather than the button element inside of it. Since the button is inside that div, floating the button alone may be causing you some issues. Here's a quick example I provided previously that you can take a look at.

    http://www.gravityhelp.com/forums/topic/trouble-positioning-submit-button-inline#post-19798

    Posted 3 years ago on Tuesday October 4, 2011 | Permalink
  5. circus
    Member

    Thank you for helping. Really appreciated. I have another issue with this same form, but only in ie7. Have posted this issue in a separate ticket.

    Thanks again,

    Ab

    Posted 3 years ago on Thursday October 6, 2011 | Permalink

This topic has been resolved and has been closed to new replies.

Support Tickets

Open A New Support Ticket
 Open A New Priority Support Ticket *

* Developer license holders only